Hostedemail Service Degredation
Incident Report for Enom
Resolved
This incident has been resolved
Posted Sep 05, 2024 - 11:20 PDT
Identified
Our team has identified the issue and is working on a fix. We thank you for your continued patience.
Posted Sep 05, 2024 - 09:09 PDT
Investigating
We are currently experiencing service degradation with our hosted email. During this time, customers may see issues logging in as well as sending and receiving emails. We appreciate your patience as our team investigates the problem.
Posted Sep 05, 2024 - 08:36 PDT
This incident affected: Basic Email Service.